RhinoCommon API
Extrusion Class |
Represents an extrusion, or objects such as beams or linearly extruded elements,
that can be represented by profile curves and two miter planes at the extremes.

SystemObject
Rhino.RuntimeCommonObject
Rhino.GeometryGeometryBase
Rhino.GeometrySurface
Rhino.GeometryExtrusion
Rhino.RuntimeCommonObject
Rhino.GeometryGeometryBase
Rhino.GeometrySurface
Rhino.GeometryExtrusion
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)

The Extrusion type exposes the following members.

Name | Description | |
---|---|---|
![]() | Extrusion |
Initializes a new instance of the Extrusion class.
|
![]() | Extrusion(SerializationInfo, StreamingContext) |
Protected serialization constructor.
|

Name | Description | |
---|---|---|
![]() | CapCount |
Gets the amount of capping surfaces.
|
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | HasBrepForm |
Returns true if the Brep.TryConvertBrep function will be successful for this object
(Inherited from GeometryBase.) |
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | IsCappedAtBottom |
Gets a value indicating whether the surface that fills the bottom profile is existing.
|
![]() | IsCappedAtTop |
Gets a value indicating whether the surface that fills the top profile is existing.
|
![]() | IsDeformable |
true if object can be accurately modified with "squishy" transformations like
projections, shears, and non-uniform scaling.
(Inherited from GeometryBase.) |
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from GeometryBase.) |
![]() | IsMiteredAtEnd |
Gets a value indicating whether a miter plane at the end is defined.
|
![]() | IsMiteredAtStart |
Returns a value indicating whether a miter plane at start is defined.
|
![]() | IsSolid |
Gets a value indicating whether there is no gap among all surfaces constructing this object.
(Overrides SurfaceIsSolid.) |
![]() | IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) |
![]() | MiterPlaneNormalAtEnd |
Gets or sets the normal of the miter plane at the end in profile coordinates.
In profile coordinates, 0,0,1 always maps to the extrusion axis
|
![]() | MiterPlaneNormalAtStart |
Gets or sets the normal of the miter plane at the start in profile coordinates.
In profile coordinates, 0,0,1 always maps to the extrusion axis
|
![]() | ObjectType |
Useful for switch statements that need to differentiate between
basic object types like points, curves, surfaces, and so on.
(Inherited from GeometryBase.) |
![]() | PathEnd |
Gets the end point of the path.
|
![]() | PathStart |
Gets the start point of the path.
|
![]() | PathTangent |
Gets the up vector of the path.
|
![]() | ProfileCount |
Gets the amount of profile curves.
|
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use sharable set of information.
(Inherited from CommonObject.) |
![]() | UserStringCount |
Gets the amount of user strings.
(Inherited from GeometryBase.) |

Name | Description | |
---|---|---|
![]() | AddInnerProfile |
Adds an inner profile.
|
![]() ![]() | ClosestPoint |
Input the parameters of the point on the surface that is closest to testPoint.
(Inherited from Surface.) |
![]() | ClosestSide |
Gets the side that is closest, in terms of 3D-distance, to a U and V parameter.
(Inherited from Surface.) |
![]() | ComponentIndex |
If this piece of geometry is a component in something larger, like a BrepEdge
in a Brep, then this function returns the component index.
(Inherited from GeometryBase.) |
![]() | ConstructConstObject |
Assigns a parent object and a subobject index to this.
(Inherited from CommonObject.) |
![]() ![]() | Create |
Creates an extrusion of a 3d curve (which must be planar) and a height.
|
![]() ![]() | CreateBoxExtrusion |
Gets an extrusion from a box.
|
![]() ![]() | CreateCylinderExtrusion |
Gets an extrusion form of a cylinder.
|
![]() ![]() | CreatePipeExtrusion |
Gets an extrusion form of a pipe.
|
![]() ![]() | CurvatureAt |
Computes the curvature at the given UV coordinate.
(Inherited from Surface.) |
![]() | Degree |
Returns the maximum algebraic degree of any span
(or a good estimate if curve spans are not algebraic).
(Inherited from Surface.) |
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | Dispose(Boolean) |
For derived class implementers.
(Inherited from CommonObject.)This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. In Rhino for Windows, this member is overridden by Dispose(Boolean). |
![]() | Domain | Gets the domain in a direction. (Inherited from Surface.) |
![]() | Duplicate |
Constructs a deep (full) copy of this object.
(Inherited from GeometryBase.) |
![]() | DuplicateShallow |
Constructs a light copy of this object. By "light", it is meant that the same
underlying data is used until something is done to attempt to change it. For example,
you could have a shallow copy of a very heavy mesh object and the same underlying
data will be used when doing things like inspecting the number of faces on the mesh.
If you modify the location of one of the mesh vertices, the shallow copy will create
a full duplicate of the underlying mesh data and the shallow copy will become a
deep copy.
(Inherited from GeometryBase.) |
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | (Inherited from Object.) |
![]() | Evaluate |
Evaluates a surface mathematically.
(Inherited from Surface.) |
![]() | Extend |
Extends an untrimmed surface along one edge.
(Inherited from Surface.) |
![]() | Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Inherited from CommonObject.) |
![]() | Fit | Fits a new surface through an existing surface. (Inherited from Surface.) |
![]() ![]() | FrameAt |
Computes the orient plane on a surface given a U and V parameter.
(Inherited from Surface.)This is the simple evaluation call with no error handling. |
![]() ![]() | GetBoundingBox(Boolean) |
Boundingbox solver. Gets the world axis aligned boundingbox for the geometry.
(Inherited from GeometryBase.) |
![]() ![]() | GetBoundingBox(Plane) |
Aligned Boundingbox solver. Gets the plane aligned boundingbox.
(Inherited from GeometryBase.) |
![]() | GetBoundingBox(Transform) |
Aligned Boundingbox solver. Gets the world axis aligned boundingbox for the transformed geometry.
(Inherited from GeometryBase.) |
![]() | GetBoundingBox(Plane, Box) |
Aligned Boundingbox solver. Gets the plane aligned boundingbox.
(Inherited from GeometryBase.) |
![]() | GetHashCode | (Inherited from Object.) |
![]() | GetMesh |
Obtains a reference to a specified type of mesh for this extrusion.
|
![]() | GetNextDiscontinuity |
Searches for a derivative, tangent, or curvature discontinuity.
(Inherited from Surface.) |
![]() | GetNurbsFormParameterFromSurfaceParameter |
Translates a parameter from the current surface to the parameter space of the surface returned by ToNurbsSurface.
(Inherited from Surface.) |
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetPathPlane |
Gets the 3D plane perpendicular to the path at a normalized path parameter.
|
![]() | GetProfilePlane |
Gets the 3D plane containing the profile curve at a normalized path parameter.
|
![]() | GetProfileTransformation |
Gets the transformation that maps the xy profile curve to its 3d location.
|
![]() | GetSpanVector |
Gets array of span "knots".
(Inherited from Surface.) |
![]() | GetSurfaceParameterFromNurbsFormParameter |
Translates a parameter from a value on the surface returned by ToNurbsSurface to the current surface.
(Inherited from Surface.) |
![]() ![]() | GetSurfaceSize |
Gets an estimate of the size of the rectangle that would be created
if the 3d surface where flattened into a rectangle.
(Inherited from Surface.) |
![]() | GetType | (Inherited from Object.) |
![]() | GetUserString |
Gets user string from this geometry.
(Inherited from GeometryBase.) |
![]() | GetUserStrings |
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
(Inherited from GeometryBase.) |
![]() | GetWireframe |
Constructs all the Wireframe curves for this Extrusion.
|
![]() | HasNurbsForm |
Is there a NURBS surface representation of this surface.
(Inherited from Surface.) |
![]() | InterpolatedCurveOnSurface |
Constructs an interpolated curve on a surface, using 3D points.
(Inherited from Surface.) |
![]() | InterpolatedCurveOnSurfaceUV |
Constructs an interpolated curve on a surface, using 2D surface points.
(Inherited from Surface.) |
![]() | IsAtSeam |
Tests if a surface parameter value is at a seam.
(Inherited from Surface.) |
![]() | IsAtSingularity |
Tests if a surface parameter value is at a singularity.
(Inherited from Surface.) |
![]() | IsClosed |
Gets a value indicating if the surface is closed in a direction.
(Inherited from Surface.) |
![]() | IsCone |
Determines if the surface is a portion of a cone within RhinoMath.ZeroTolerance.
(Inherited from Surface.) |
![]() | IsCone(Double) | Determines if the surface is a portion of a cone within a given tolerance. (Inherited from Surface.) |
![]() | IsContinuous |
Tests continuity at a surface parameter value.
(Inherited from Surface.) |
![]() | IsCylinder |
Determines if the surface is a portion of a cylinder within RhinoMath.ZeroTolerance.
(Inherited from Surface.) |
![]() | IsCylinder(Double) | Determines if the surface is a portion of a cylinder within a given tolerance. (Inherited from Surface.) |
![]() | IsIsoparametric(BoundingBox) |
Determines if a 2d bounding box is iso-parameteric in the parameter space of this surface.
(Inherited from Surface.) |
![]() | IsIsoparametric(Curve) |
Determines if a 2d curve is iso-parameteric in the parameter space of this surface.
(Inherited from Surface.) |
![]() | IsIsoparametric(Curve, Interval) |
Determines if a 2D curve is iso-parameteric in the parameter space of this surface.
(Inherited from Surface.) |
![]() ![]() | IsoCurve | Gets isoparametric curve. (Inherited from Surface.) |
![]() | IsPeriodic |
Gets a value indicating if thr surface is periodic in a direction (default is false).
(Inherited from Surface.) |
![]() ![]() | IsPlanar |
Tests a surface to see if it is planar to zero tolerance.
(Inherited from Surface.) |
![]() | IsPlanar(Double) |
Tests a surface to see if it is planar to a given tolerance.
(Inherited from Surface.) |
![]() | IsSingular |
true if surface side is collapsed to a point.
(Inherited from Surface.) |
![]() | IsSphere |
Determines if the surface is a portion of a sphere within RhinoMath.ZeroTolerance.
(Inherited from Surface.) |
![]() | IsSphere(Double) |
Determines if the surface is a portion of a sphere within a given tolerance.
(Inherited from Surface.) |
![]() | IsTorus | Determines if the surface is a portion of a torus within RhinoMath.ZeroTolerance. (Inherited from Surface.) |
![]() | IsTorus(Double) | Determines if the surface is a portion of a torus within a given tolerance. (Inherited from Surface.) |
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | LocalClosestPoint |
Find parameters of the point on a surface that is locally closest to
the testPoint. The search for a local close point starts at seed parameters.
(Inherited from Surface.) |
![]() | MakeDeformable |
If possible, converts the object into a form that can be accurately modified
with "squishy" transformations like projections, shears, an non-uniform scaling.
(Inherited from GeometryBase.) |
![]() | MemberwiseClone | (Inherited from Object.) |
![]() | MemoryEstimate |
Computes an estimate of the number of bytes that this object is using in memory.
(Inherited from GeometryBase.) |
![]() | NonConstOperation |
For derived classes implementers.
(Inherited from CommonObject.)Defines the necessary implementation to free the instance from being const. In Rhino for Windows, this member is overridden by NonConstOperation. |
![]() ![]() | NormalAt |
Computes the surface normal at a point.
(Inherited from Surface.)This is the simple evaluation call - it does not support error handling. |
![]() | Offset |
Constructs a new surface which is offset from the current surface.
(Inherited from Surface.) |
![]() | OnSwitchToNonConst |
Is called when a non-const operation occurs.
(Inherited from GeometryBase.) |
![]() | PathLineCurve |
Gets the line-like curve that is the conceptual axis of the extrusion.
|
![]() | PointAt |
Evaluates a point at a given parameter.
(Inherited from Surface.) |
![]() | Profile3d(ComponentIndex) |
Gets one of the profiles.
|
![]() | Profile3d(Int32, Double) |
Gets a transversal isocurve of the extruded profile.
|
![]() | ProfileIndex |
Gets the index of the profile curve at a domain related to a parameter.
|
![]() | Pullback(Curve, Double) |
Pulls a 3d curve back to the surface's parameter space.
(Inherited from Surface.) |
![]() | Pullback(Curve, Double, Interval) |
Pulls a 3d curve back to the surface's parameter space.
(Inherited from Surface.) |
![]() | Pushup(Curve, Double) |
Computes a 3d curve that is the composite of a 2d curve and the surface map.
(Inherited from Surface.) |
![]() | Pushup(Curve, Double, Interval) |
Computes a 3d curve that is the composite of a 2d curve and the surface map.
(Inherited from Surface.) |
![]() | Rebuild |
Rebuilds an existing surface to a given degree and point count.
(Inherited from Surface.) |
![]() | RebuildOneDirection |
Rebuilds an existing surface with a new surface to a given point count in either the u or v directions independently.
(Inherited from Surface.) |
![]() | Reverse(Int32) |
Reverses parameterization Domain changes from [a,b] to [-b,-a]
(Inherited from Surface.) |
![]() | Reverse(Int32, Boolean) |
Same as Reverse, but if inPlace is set to true this Surface is modified
instead of a new copy being created.
(Inherited from Surface.) |
![]() | Rotate |
Rotates the object about the specified axis. A positive rotation
angle results in a counter-clockwise rotation about the axis (right hand rule).
(Inherited from GeometryBase.) |
![]() | Scale |
Scales the object by the specified factor. The scale is centered at the origin.
(Inherited from GeometryBase.) |
![]() | SetDomain |
Sets the domain in a direction.
(Inherited from Surface.) |
![]() | SetOuterProfile |
Sets the outer profile of the extrusion.
|
![]() | SetPathAndUp |
Allows to set the two points at the extremes and the up vector.
|
![]() | SetUserString |
Attach a user string (key,value combination) to this geometry.
(Inherited from GeometryBase.) |
![]() | ShortPath |
Constructs a geodesic between 2 points, used by ShortPath command in Rhino.
(Inherited from Surface.) |
![]() | Smooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem) |
Smooths a surface by averaging the positions of control points in a specified region.
(Inherited from Surface.) |
![]() | Smooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane) |
Smooths a surface by averaging the positions of control points in a specified region.
(Inherited from Surface.) |
![]() | SpanCount |
Gets number of smooth nonempty spans in the parameter direction.
(Inherited from Surface.) |
![]() | Split |
Splits (divides) the surface into two parts at the specified parameter
(Inherited from Surface.) |
![]() | ToBrep |
Converts the surface into a Brep.
(Inherited from Surface.) |
![]() | ToBrep(Boolean) |
Constructs a brep form of the extrusion. The outer profile is always the first face of the brep.
If there are inner profiles, additional brep faces are created for each profile. If the
outer profile is closed, then end caps are added as the last two faces of the brep.
|
![]() | ToNurbsSurface |
Gets a NURBS surface representation of this surface. Default
tolerance of 0.0 is used.
(Inherited from Surface.) |
![]() | ToNurbsSurface(Double, Int32) |
Gets a NURBS surface representation of this surface.
(Inherited from Surface.) |
![]() | ToString | (Inherited from Object.) |
![]() | Transform |
Transforms the geometry. If the input Transform has a SimilarityType of
OrientationReversing, you may want to consider flipping the transformed
geometry after calling this function when it makes sense. For example,
you may want to call Flip() on a Brep after transforming it.
(Inherited from GeometryBase.) |
![]() | Translate(Vector3d) | Translates the object along the specified vector. (Inherited from GeometryBase.) |
![]() | Translate(Double, Double, Double) | Translates the object along the specified vector. (Inherited from GeometryBase.) |
![]() | Transpose |
Transposes surface parameterization (swap U and V)
(Inherited from Surface.) |
![]() | Transpose(Boolean) |
Transposes surface parameterization (swap U and V)
(Inherited from Surface.) |
![]() | Trim |
Constructs a sub-surface that covers the specified UV trimming domain.
(Inherited from Surface.) |
![]() | TryGetCone(Cone) | Tests a surface to see if it is a portion of a cone within RhinoMath.ZeroTolerance and return the cone. (Inherited from Surface.) |
![]() | TryGetCone(Cone, Double) | Tests a surface to see if it is a portion of a cone and returns the cone. (Inherited from Surface.) |
![]() | TryGetCylinder(Cylinder) | Tests a surface to see if it is a portion of a cylinder within RhinoMath.ZeroTolerance and return the cylinder. (Inherited from Surface.) |
![]() | TryGetCylinder(Cylinder, Double) | Tests a surface to see if it is a portion of a cylinder and return the infinite cylinder. (Inherited from Surface.) |
![]() | TryGetFiniteCylinder | Tests a surface with the assumption that it might be a right circular cylinder and returns this geometry. (Inherited from Surface.) |
![]() | TryGetPlane(Plane) | Tests a surface for planarity and return the plane. (Inherited from Surface.) |
![]() ![]() | TryGetPlane(Plane, Double) | Tests a surface for planarity and return the plane. (Inherited from Surface.) |
![]() | TryGetSphere(Sphere) | Test a surface to see if it is a portion of a sphere and return the sphere. (Inherited from Surface.) |
![]() | TryGetSphere(Sphere, Double) | Test a surface to see if it is a portion of a sphere and return the sphere. (Inherited from Surface.) |
![]() | TryGetTorus(Torus) | Tests a surface to see if it is a portion of a torus within RhinoMath.ZeroTolerance and returns the torus. (Inherited from Surface.) |
![]() | TryGetTorus(Torus, Double) | Tests a surface to see if it is a portion of a torus and returns the torus. (Inherited from Surface.) |
![]() | WallEdge |
Gets one of the longitudinal curves along the beam or extrusion.
|
![]() | WallSurface |
Gets one of the longitudinal surfaces of the extrusion.
|

Rhino for Mac
Supported in: 5.4Rhino for Windows
Supported in: 6.8