Intersection Class

Intersection Class

Provides static methods for the computation of intersections, projections, sections and similar.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.IntersectIntersection

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class Intersection
Public NotInheritable Class Intersection

The Intersection type exposes the following members.

Methods
  NameDescription
Public methodStatic memberBrepBrep
Intersects two Breps.
Public methodStatic memberBrepPlane
Intersects a Brep with an (infinite) plane.
Public methodStatic memberBrepSurface
Intersects a Brep and a Surface.
Public methodStatic memberCode exampleCurveBrep(Curve, Brep, Double, Curve, Point3d)
Intersects a curve with a Brep. This function returns the 3D points of intersection and 3D overlap curves. If an error occurs while processing overlap curves, this function will return false, but it will still provide partial results.
Public methodStatic memberCurveBrep(Curve, Brep, Double, Double, Double)
Intersect a curve with a Brep. This function returns the intersection parameters on the curve.
Public methodStatic memberCurveBrep(Curve, Brep, Double, Curve, Point3d, Double)
Intersects a curve with a Brep. This function returns the 3D points of intersection, curve parameters at the intersection locations, and 3D overlap curves. If an error occurs while processing overlap curves, this function will return false, but it will still provide partial results.
Public methodStatic memberCurveBrepFace
Intersects a curve with a Brep face.
Public methodStatic memberCode exampleCurveCurve
Finds the intersections between two curves.
Public methodStatic memberCurveLine
Intersects a curve and an infinite line.
Public methodStatic memberCurvePlane
Intersects a curve with an (infinite) plane.
Public methodStatic memberCurveSelf
Finds the places where a curve intersects itself.
Public methodStatic memberCode exampleCurveSurface(Curve, Surface, Double, Double)
Intersects a curve and a surface.
Public methodStatic memberCurveSurface(Curve, Interval, Surface, Double, Double)
Intersects a (sub)curve and a surface.
Public methodStatic memberLineBox(Line, BoundingBox, Double, Interval)
Intersects an infinite line and an axis aligned bounding box.
Public methodStatic memberLineBox(Line, Box, Double, Interval)
Intersects an infinite line with a box volume.
Public methodStatic memberCode exampleLineCircle
Intersects a line with a circle using exact calculations.
Public methodStatic memberLineCylinder
Intersects a line with a cylinder using exact calculations.
Public methodStatic memberCode exampleLineLine(Line, Line, Double, Double)
Finds the closest point between two infinite lines.
Public methodStatic memberLineLine(Line, Line, Double, Double, Double, Boolean)
Intersects two lines.
Public methodStatic memberLinePlane
Intersects a line and a plane. This function only returns true if the intersection result is a single point (i.e. if the line is coincident with the plane then no intersection is assumed).
Public methodStatic memberLineSphere
Intersects a line with a sphere using exact calculations.
Public methodStatic memberMeshLine
Finds the intersection of a mesh and a line
Public methodStatic memberMeshMeshAccurate
Intersects two meshes. Overlaps and near misses are handled.
Public methodStatic memberMeshMeshFast
Quickly intersects two meshes. Overlaps and near misses are ignored.
Public methodStatic memberMeshPlane(Mesh, Plane)
Intersects a mesh with an (infinite) plane.
Public methodStatic memberMeshPlane(Mesh, IEnumerablePlane)
Intersects a mesh with a collection of (infinite) planes.
Public methodStatic memberMeshPolyline
Finds the intersection of a mesh and a polyline.
Public methodStatic memberMeshRay(Mesh, Ray3d)
Finds the first intersection of a ray with a mesh.
Public methodStatic memberMeshRay(Mesh, Ray3d, Int32)
Finds the first intersection of a ray with a mesh.
Public methodStatic memberPlaneCircle
Intersects a plane with a circle using exact calculations.
Public methodStatic memberPlanePlane
Intersects two planes and return the intersection line. If the planes are parallel or coincident, no intersection is assumed.
Public methodStatic memberPlanePlanePlane
Intersects three planes to find the single point they all share.
Public methodStatic memberPlaneSphere
Intersects a plane with a sphere using exact calculations.
Public methodStatic memberCode exampleProjectPointsToBreps
Projects points onto breps.
Public methodStatic memberProjectPointsToBrepsEx
Projects points onto breps.
Public methodStatic memberProjectPointsToMeshes
Projects points onto meshes.
Public methodStatic memberCode exampleProjectPointsToMeshesEx
Projects points onto meshes.
Public methodStatic memberRayShoot
Computes point intersections that occur when shooting a ray to a collection of surfaces.
Public methodStatic memberSphereSphere
Intersects two spheres using exact calculations.
Public methodStatic memberSurfaceSurface
Intersects two Surfaces.
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also