RhinoCommon API
Leader Class |
Leader geometry class

SystemObject
Rhino.RuntimeCommonObject
Rhino.GeometryGeometryBase
Rhino.GeometryAnnotationBase
Rhino.GeometryLeader
Rhino.RuntimeCommonObject
Rhino.GeometryGeometryBase
Rhino.GeometryAnnotationBase
Rhino.GeometryLeader
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)

The Leader type exposes the following members.

Name | Description | |
---|---|---|
![]() | Leader | Constructor |
![]() | Leader(SerializationInfo, StreamingContext) |
Protected constructor used in serialization.
|

Name | Description | |
---|---|---|
![]() | AlternateDimensionLengthDisplay |
Alternate length display units and format
(Inherited from AnnotationBase.) |
![]() | AnnotationType |
Type of annotation
(Inherited from AnnotationBase.) |
![]() | Curve | Gets the curve used by this leader |
![]() | DimensionLengthDisplay |
Length display units and format
(Inherited from AnnotationBase.) |
![]() | DimensionScale |
Gets or sets the dimension scale
(Inherited from AnnotationBase.) |
![]() | DimensionStyle |
If there are no overrides then the parent style is returned otherwise the dimension style saved with the annotation is returned.
(Inherited from AnnotationBase.) |
![]() | DimensionStyleId |
Id of this annotation's parent dimstyle
If this annotation has overrides to dimstyle properties,
those overrides will be represented in the DimensionStyle
returned by DimensionStyle(ParentStyle)
(Inherited from AnnotationBase.) |
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | DrawForward |
Gets or sets whether the text is oriented towards the reader when viewed from behind
(Inherited from AnnotationBase.) |
![]() | FirstCharFont |
Returns the font used by the first run of text in an annotation
(Inherited from AnnotationBase.) |
![]() | Font |
The base Font for the text of the annotation. The text string is rich text and therefore a different font that the base font can be associated with sub strings of the text
(Inherited from AnnotationBase.) |
![]() | FontIndex | Obsolete. Obsolete; use Font property instead (Inherited from AnnotationBase.) |
![]() | FormatWidth | Text format width (Wrapping rectangle) (Inherited from AnnotationBase.) |
![]() | HasBrepForm |
Returns true if the Brep.TryConvertBrep function will be successful for this object
(Inherited from GeometryBase.) |
![]() | HasPropertyOverrides | (Inherited from AnnotationBase.) |
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | Index |
Index of DimensionStyle in document DimStyle table used by the dimension.
(Inherited from AnnotationBase.) |
![]() | IsDeformable |
true if object can be accurately modified with "squishy" transformations like
projections, shears, and non-uniform scaling.
(Inherited from GeometryBase.) |
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from GeometryBase.) |
![]() | IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) |
![]() | LeaderArrowBlockId |
Id of the block used as the arrow for the leader when the arrow type is 'User arrow'
|
![]() | LeaderArrowSize |
The size of the leader arrow
|
![]() | LeaderArrowType |
The arrowhead type for the leader
|
![]() | LeaderContentAngleStyle |
Angle for text of leader text
|
![]() | LeaderCurveStyle |
The style of the leader curve: polyline or spline
|
![]() | LeaderHasLanding |
Returns true if the leader has a landing line
|
![]() | LeaderLandingLength |
Gets or sets the length of the landing line
|
![]() | LeaderTextHorizontalAlignment |
Gets or sets the horizontal alignment of the leader's text
|
![]() | LeaderTextVerticalAlignment |
Gets or sets the vertical alignment of the leader's text
|
![]() | MaskColor |
Color to use for drawing a text mask when it is enabled. If the mask is
enabled and MaskColor is System.Drawing.Color.Transparent, then the
viewport's color will be used for the MaskColor
(Inherited from AnnotationBase.) |
![]() | MaskColorSource |
Gets or sets whether the mask background color is from the background or from a color
(Inherited from AnnotationBase.) |
![]() | MaskEnabled |
Determines whether or not to draw a Text Mask
(Inherited from AnnotationBase.) |
![]() | MaskOffset |
Offset for the border around text of the rectangle used to draw the mask. This
value multiplied by TextHeight is the offset on each side of the tight rectangle
around the text characters to the mask rectangle. The default value is 0.1.
(Inherited from AnnotationBase.) |
![]() | MaskUsesViewportColor |
If true, the viewport's color is used for the mask color. If
false, the color defined by MaskColor is used
(Inherited from AnnotationBase.) |
![]() | NumericValue |
Gets the numeric value, depending on geometry type.
(Inherited from AnnotationBase.)LinearDimension: distance between arrow tips RadialDimension: radius or diamater depending on type AngularDimension: angle in degrees Leader or Text: UnsetValue |
![]() | ObjectType |
Useful for switch statements that need to differentiate between
basic object types like points, curves, surfaces, and so on.
(Inherited from GeometryBase.) |
![]() | ParentDimensionStyle |
The parent dimension style associated with this annotation
(Inherited from AnnotationBase.) |
![]() | PlainText |
Text stripped of RTF formatting information
(Inherited from AnnotationBase.) |
![]() | Plane | Plane that this annotation lies on (Inherited from AnnotationBase.) |
![]() | Points2D |
Get or set the 2d points defining the curve used by this leader
|
![]() | Points3D |
Get or set the 3d points defining the curve used by this leader
|
![]() | RichText |
Text including additional RTF formatting information
(Inherited from AnnotationBase.) |
![]() | Text |
Text including additional RTF formatting information
(Inherited from AnnotationBase.) |
![]() | TextFormula |
See RichText
(Inherited from AnnotationBase.) |
![]() | TextHasRtfFormatting | (Inherited from AnnotationBase.) |
![]() | TextHeight |
AnnotationBase.TextHeight
Gets the parent dimstyle for the annotation and
gets or sets the text height in the dimstyle
(Inherited from AnnotationBase.) |
![]() | TextIsWrapped |
Is text wrapping on
(Inherited from AnnotationBase.) |
![]() | TextModelWidth |
Width of text in the model
(Inherited from AnnotationBase.) |
![]() | TextRotationDegrees |
Rotation of text in degrees
(Inherited from AnnotationBase.) |
![]() | TextRotationRadians |
Rotation of text in radians
(Inherited from AnnotationBase.) |
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use sharable set of information.
(Inherited from CommonObject.) |
![]() | UserStringCount |
Gets the amount of user strings.
(Inherited from GeometryBase.) |

Name | Description | |
---|---|---|
![]() | ClearPropertyOverrides |
Clears all overriden properties for this annotation
(Inherited from AnnotationBase.) |
![]() | ComponentIndex |
If this piece of geometry is a component in something larger, like a BrepEdge
in a Brep, then this function returns the component index.
(Inherited from GeometryBase.) |
![]() | ConstructConstObject |
Assigns a parent object and a subobject index to this.
(Inherited from CommonObject.) |
![]() ![]() | Create |
Creates a Leader geometry object
|
![]() ![]() | CreateWithRichText |
Creates a Leader geometry object
|
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | Dispose(Boolean) |
For derived class implementers.
(Inherited from CommonObject.)This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. In Rhino for Windows, this member is overridden by Dispose(Boolean). |
![]() | Duplicate |
Constructs a deep (full) copy of this object.
(Inherited from GeometryBase.) |
![]() | DuplicateShallow |
Constructs a light copy of this object. By "light", it is meant that the same
underlying data is used until something is done to attempt to change it. For example,
you could have a shallow copy of a very heavy mesh object and the same underlying
data will be used when doing things like inspecting the number of faces on the mesh.
If you modify the location of one of the mesh vertices, the shallow copy will create
a full duplicate of the underlying mesh data and the shallow copy will become a
deep copy.
(Inherited from GeometryBase.) |
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | (Inherited from Object.) |
![]() | Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Inherited from CommonObject.) |
![]() ![]() | GetBoundingBox(Boolean) |
Boundingbox solver. Gets the world axis aligned boundingbox for the geometry.
(Inherited from GeometryBase.) |
![]() ![]() | GetBoundingBox(Plane) |
Aligned Boundingbox solver. Gets the plane aligned boundingbox.
(Inherited from GeometryBase.) |
![]() | GetBoundingBox(Transform) |
Aligned Boundingbox solver. Gets the world axis aligned boundingbox for the transformed geometry.
(Inherited from GeometryBase.) |
![]() | GetBoundingBox(Plane, Box) |
Aligned Boundingbox solver. Gets the plane aligned boundingbox.
(Inherited from GeometryBase.) |
![]() | GetDimensionStyle |
Return the proper dimension style from which to get properties
for this annotation object
If this object has style overrides, those will be included in the
returned dimension style and the style will be updated to include
the current state of the parent style for non-overridden fields
(Inherited from AnnotationBase.) |
![]() | GetHashCode | (Inherited from Object.) |
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetType | (Inherited from Object.) |
![]() | GetUserString |
Gets user string from this geometry.
(Inherited from GeometryBase.) |
![]() | GetUserStrings |
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
(Inherited from GeometryBase.) |
![]() | IsPropertyOverridden |
Returns true if a property is overridden
(Inherited from AnnotationBase.) |
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | MakeDeformable |
If possible, converts the object into a form that can be accurately modified
with "squishy" transformations like projections, shears, an non-uniform scaling.
(Inherited from GeometryBase.) |
![]() | MemberwiseClone | (Inherited from Object.) |
![]() | MemoryEstimate |
Computes an estimate of the number of bytes that this object is using in memory.
(Inherited from GeometryBase.) |
![]() | NonConstOperation |
For derived classes implementers.
(Inherited from CommonObject.)Defines the necessary implementation to free the instance from being const. In Rhino for Windows, this member is overridden by NonConstOperation. |
![]() | OnSwitchToNonConst |
Is called when a non-const operation occurs.
(Inherited from GeometryBase.) |
![]() | Rotate |
Rotates the object about the specified axis. A positive rotation
angle results in a counter-clockwise rotation about the axis (right hand rule).
(Inherited from GeometryBase.) |
![]() | Scale |
Scales the object by the specified factor. The scale is centered at the origin.
(Inherited from GeometryBase.) |
![]() | SetBold | (Inherited from AnnotationBase.) |
![]() | SetFacename | (Inherited from AnnotationBase.) |
![]() | SetItalic | (Inherited from AnnotationBase.) |
![]() | SetOverrideDimStyle |
Set a style including overrides for this annotation object.
The DimensionStyle OverrideStyle must have the override fields marked
as overridden and must have it's Id set to nil.
Use DimensinoStyle.SetFieldOverride(Field field) and related functions
to manage override settings. To override a field, the field value must be set
and the field must be marked as an override.
The DimensionStyle passed in here must not be in the dimstyle table
(Inherited from AnnotationBase.) |
![]() | SetRichText | (Inherited from AnnotationBase.) |
![]() | SetUnderline | (Inherited from AnnotationBase.) |
![]() | SetUserString |
Attach a user string (key,value combination) to this geometry.
(Inherited from GeometryBase.) |
![]() | ToString | (Inherited from Object.) |
![]() | Transform |
Transforms the geometry. If the input Transform has a SimilarityType of
OrientationReversing, you may want to consider flipping the transformed
geometry after calling this function when it makes sense. For example,
you may want to call Flip() on a Brep after transforming it.
(Inherited from GeometryBase.) |
![]() | Translate(Vector3d) | Translates the object along the specified vector. (Inherited from GeometryBase.) |
![]() | Translate(Double, Double, Double) | Translates the object along the specified vector. (Inherited from GeometryBase.) |
![]() | WrapText |
Wrap text
(Inherited from AnnotationBase.) |

Rhino for Mac
Supported in: 5.4Rhino for Windows
Supported in: 6.8