MeshPoint Class

MeshPoint Class

Represents a point that is found on a mesh.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryMeshPoint

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshPoint
Public Class MeshPoint

The MeshPoint type exposes the following members.

Properties
  NameDescription
Public propertyComponentIndex
Gets the component index of the intersecting element in the mesh.
Public propertyEdgeIndex
When set, EdgeIndex is an index of an edge in the mesh's edge list.
Public propertyEdgeParameter
Edge parameter when found.
Public propertyFaceIndex
FaceIndex is an index of a face in mesh.Faces. When ComponentIndex refers to a vertex, any face that uses the vertex may appear as FaceIndex. When ComponenctIndex refers to an Edge or EdgeIndex is set, then any face that uses that edge may appear as FaceIndex.
Public propertyMesh
The mesh that is ralated to this point.
Public propertyPoint
Gets the location (position) of this point.
Public propertyT
Barycentric quad coordinates for the point on the mesh face mesh.Faces[FaceIndex]. If the face is a triangle disregard T[3] (it should be set to 0.0). If the face is a quad and is split between vertexes 0 and 2, then T[3] will be 0.0 when point is on the triangle defined by vi[0], vi[1], vi[2], and T[1] will be 0.0 when point is on the triangle defined by vi[0], vi[2], vi[3]. If the face is a quad and is split between vertexes 1 and 3, then T[2] will be 0.0 when point is on the triangle defined by vi[0], vi[1], vi[3], and m_t[0] will be 0.0 when point is on the triangle defined by vi[1], vi[2], vi[3].
Public propertyTriangle
Face triangle where the intersection takes place:

0 is unset

A is 0,1,2

B is 0,2,3

C is 0,1,3

D is 1,2,3

Top
Methods
  NameDescription
Public methodGetTriangle
Gets the mesh face indices of the triangle where the intersection is on the face takes into consideration the way the quad was split during the intersection.
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also