MeshingParameterTextureRange Enumeration

MeshingParameterTextureRange Enumeration

Defines how to pack render/meshes textures.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum MeshingParameterTextureRange
Public Enumeration MeshingParameterTextureRange
Members
  Member nameValueDescription
Unset0This value is not set.
UnpackedUnscaledNormalized1 Rach face has a normalized texture range [0,1]x[0,1]. The normalized coordinate is calculated using the entire surface domain. For meshes of trimmed surfaces when the active area is a small subset of the entire surface, there will be large regions of unused texture space in [0,1]x[0,1]. When the 3d region being meshed is far from being square-ish, there will be a substantual amount of distortion mapping [0,1]x[0,1] texture space to the 3d mesh.
PackedScaledNormalized2 Each face is assigned a texture range that is a subrectangle of [0,1]x[0,1]. The subrectangles are mutually disjoint and packed into into [0,1]x[0,1] in a way that minimizes distortion and maximizes the coverage of [0,1]x[0,1]. When the surface or surfaces being meshed are trimmed, this option takes into account only the region of the base surface the mesh covers and uses as much of [0,1]x[0,1] as possible. (default)
Version Information

Rhino for Windows

Supported in: 6.8
See Also