OrdinateDimension Class

OrdinateDimension Class

Represents an ordinate dimension
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeCommonObject
    Rhino.GeometryGeometryBase
      Rhino.GeometryAnnotationBase
        Rhino.GeometryOrdinateDimension

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class OrdinateDimension : AnnotationBase
<SerializableAttribute>
Public Class OrdinateDimension
	Inherits AnnotationBase

The OrdinateDimension type exposes the following members.

Constructors
  NameDescription
Public methodOrdinateDimension
Initializes a new instance of the OrdinateDimension class
Protected methodOrdinateDimension(SerializationInfo, StreamingContext)
Protected constructor used in serialization.
Top
Properties
  NameDescription
Public propertyDefPoint
Public propertyKinkOffset1
Public propertyKinkOffset2
Public propertyKinkPoint1
Public propertyKinkPoint2
Public propertyLeaderPoint
Public propertyNumericValue
Gets the numeric value, depending on geometry type.

LinearDimension: distance between arrow tips

RadialDimension: radius or diamater depending on type

AngularDimension: angle in degrees

Leader or Text: UnsetValue

In Rhino for Windows 6.8, this member is inherited from DimensionNumericValue.

In Rhino for Windows 6.8, this member is inherited from DimensionTextFormula.
Top
Methods
  NameDescription
Public methodAdjustFromPoints
Update Dimension geometry from point locations
Public methodStatic memberCreate
Initialize Dimension parameters
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

In Rhino for Windows, this member is overridden by Dispose(Boolean).
Public methodGet3dPoints
Get locations of dimension's 3d points
Public methodGetDisplayLines
Public methodGetDistanceDisplayText
Public methodGetTextRectangle

In Rhino for Windows, this member is overridden by NonConstOperation.
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also