SumSurface Class

SumSurface Class

Represents a sum surface, or an extrusion of a curve along a curved path.
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeCommonObject
    Rhino.GeometryGeometryBase
      Rhino.GeometrySurface
        Rhino.GeometrySumSurface

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class SumSurface : Surface
<SerializableAttribute>
Public Class SumSurface
	Inherits Surface

The SumSurface type exposes the following members.

Constructors
  NameDescription
Protected methodSumSurface
Protected constructor for internal use.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Public methodStatic memberCreate
Constructs a new sum surface by extruding a curve A along a path B.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

In Rhino for Windows, this member is overridden by Dispose(Boolean).

In Rhino for Windows, this member is overridden by NonConstOperation.
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also