SweepOneRail Class

SweepOneRail Class

Utility class for generating breps by sweeping cross section curves over a single rail curve.
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySweepOneRail

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SweepOneRail
Public Class SweepOneRail

The SweepOneRail type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleSweepOneRail
Initializes a new instance of the SweepOneRail class
Top
Properties
  NameDescription
Public propertyAngleToleranceRadians
Public propertyClosedSweep
If the input rail is closed, ClosedSweep determines if the swept breps will also be closed.
Public propertyGlobalShapeBlending
If true, the sweep is linearly blended from one end to the other, creating sweeps that taper from one cross-section curve to the other. If false, the sweep stays constant at the ends and changes more rapidly in the middle.
Public propertyIsFreeform
Public propertyIsRoadlike
Public propertyIsRoadlikeFront
Public propertyIsRoadlikeTop
Public propertyIsRoadlineRight
Public propertyMiterType
0: don't miter, 1: intersect surfaces and trim sweeps, 2: rotate shapes at kinks and don't trim.
Public propertySweepTolerance
Top
Methods
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also