RenderMaterial Class

RenderMaterial Class

[Missing <summary> documentation for "T:Rhino.Render.RenderMaterial"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderContent
    Rhino.RenderRenderMaterial

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class RenderMaterial : RenderContent
Public MustInherit Class RenderMaterial
	Inherits RenderContent

The RenderMaterial type exposes the following members.

Constructors
  NameDescription
Protected methodRenderMaterial
Initializes a new instance of the RenderMaterial class
Top
Properties
  NameDescription
Public propertyDefaultPreviewBackgroundType
Set or get the default scene background for the image that appears in preview panes
Public propertyDefaultPreviewGeometryType
Set or get the default geometry that appears in preview panes
Public propertyDefaultPreviewSize
The default preview geometry size
Public propertyStatic memberGemMaterialGuid
Public propertyStatic memberGlassMaterialGuid
Public propertyStatic memberMetalMaterialGuid
Public propertyStatic memberPaintMaterialGuid
Public propertyStatic memberPictureMaterialGuid
Public propertyStatic memberPlasterMaterialGuid
Public propertyStatic memberPlasticMaterialGuid
Public propertySmellsLikeGem
Public propertySmellsLikeGlass
Public propertySmellsLikeMetal
Public propertySmellsLikePaint
Public propertySmellsLikePlaster
Public propertySmellsLikePlastic
Public propertySmellsLikeTexturedGem
Public propertySmellsLikeTexturedGlass
Public propertySmellsLikeTexturedMetal
Public propertySmellsLikeTexturedPaint
Public propertySmellsLikeTexturedPlaster
Public propertySmellsLikeTexturedPlastic
Top
Methods
  NameDescription
Public methodStatic memberCreateBasicMaterial(Material)
Constructs a new basic material from a Material.
Public methodStatic memberCreateBasicMaterial(Material, RhinoDoc)
Public methodGetTextureAmountFromUsage
Public methodGetTextureFromUsage
Public methodGetTextureOnFromUsage
Public methodSimulateMaterial(Boolean)
Override this function to provide a Rhino.DocObjects.Material definition for this material to be used by other rendering engines including the display.
Public methodSimulateMaterial(Material, Boolean)
Override this function to provide a Rhino.DocObjects.Material definition for this material to be used by other rendering engines including the display.
Public methodTextureChildSlotName
Override this function to provide information about which texture is used for the standard (ie - defined in ON_Texture) texture channels.
Top
Version Information

Rhino for Windows

Supported in: 6.8
See Also