RhinoCommon API
RhinoViewportGetPickTransform Method (Rectangle) |
Takes a rectangle in screen coordinates and returns a transformation
that maps the 3d frustum defined by the rectangle to a -1/+1 clipping
coordinate box.
Namespace: Rhino.Display
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public Transform GetPickTransform( Rectangle clientRectangle )
Public Function GetPickTransform ( clientRectangle As Rectangle ) As Transform
Parameters
- clientRectangle
- Type: System.DrawingRectangle
The client rectangle.
Return Value
Type: TransformA transformation matrix.