RhinoCommon API
RhinoViewportGetWorldToScreenScale Method |
Gets the world to screen size scaling factor at a point in frustum.
Namespace: Rhino.Display
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public bool GetWorldToScreenScale( Point3d pointInFrustum, out double pixelsPerUnit )
Public Function GetWorldToScreenScale ( pointInFrustum As Point3d, <OutAttribute> ByRef pixelsPerUnit As Double ) As Boolean
Parameters
- pointInFrustum
- Type: Rhino.GeometryPoint3d
A point in frustum. - pixelsPerUnit
- Type: SystemDouble
scale = number of pixels per world unit at the 3d point.This out parameter is assigned during this call.
Return Value
Type: Booleantrue if the operation is successful.