RhinoCommon API
MaterialTableModify Method |
Modify material settings.
Namespace: Rhino.DocObjects.Tables
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public bool Modify( Material newSettings, int materialIndex, bool quiet )
Public Function Modify ( newSettings As Material, materialIndex As Integer, quiet As Boolean ) As Boolean
Parameters
- newSettings
- Type: Rhino.DocObjectsMaterial
This information is copied. - materialIndex
- Type: SystemInt32
zero based index of material to set. This must be in the range 0 <= layerIndex < MaterialTable.Count. - quiet
- Type: SystemBoolean
if true, information message boxes pop up when illegal changes are attempted.
Return Value
Type: Booleantrue if successful. false if materialIndex is out of range or the settings attempt to lock or hide the current material.