File3dmObjectTable.AddPoint Method (Point3f, ObjectAttributes)

File3dmObjectTableAddPoint Method (Point3f, ObjectAttributes)

Adds a point object to the document.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddPoint(
	Point3f point,
	ObjectAttributes attributes
)
Public Function AddPoint ( 
	point As Point3f,
	attributes As ObjectAttributes
) As Guid

Parameters

point
Type: Rhino.GeometryPoint3f
location of point.
attributes
Type: Rhino.DocObjectsObjectAttributes
attributes to apply to point.

Return Value

Type: Guid
A unique identifier for the object.
See Also