RhinoCommon API
File3dmReadArchiveVersion Method |
Reads only the archive 3dm version from an existing 3dm file.
Namespace: Rhino.FileIO
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.10

public static int ReadArchiveVersion( string path )
Public Shared Function ReadArchiveVersion ( path As String ) As Integer
Parameters
- path
- Type: SystemString
The file from which to read the archive version.
Return Value
Type: Int32The 3dm file archive version.

Exception | Condition |
---|---|
FileNotFoundException | If path does not exist, is null or cannot be accessed because of permissions. |