RhinoCommon API
AreaMassPropertiesCompute Method (Hatch) |
Computes an AreaMassProperties for a hatch.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public static AreaMassProperties Compute( Hatch hatch )
Public Shared Function Compute ( hatch As Hatch ) As AreaMassProperties
Parameters
- hatch
- Type: Rhino.GeometryHatch
Hatch to measure.
Return Value
Type: AreaMassPropertiesThe AreaMassProperties for the given hatch or null on failure.

Exception | Condition |
---|---|
ArgumentNullException | When hatch is null. |