RhinoCommon API
AreaMassPropertiesCompute Method (Surface, Boolean, Boolean, Boolean, Boolean) |
Compute the AreaMassProperties for a single Surface.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 6.3

public static AreaMassProperties Compute( Surface surface, bool area, bool firstMoments, bool secondMoments, bool productMoments )
Public Shared Function Compute ( surface As Surface, area As Boolean, firstMoments As Boolean, secondMoments As Boolean, productMoments As Boolean ) As AreaMassProperties
Parameters
- surface
- Type: Rhino.GeometrySurface
Surface to measure. - area
- Type: SystemBoolean
true to calculate area. - firstMoments
- Type: SystemBoolean
true to calculate area first moments, area, and area centroid. - secondMoments
- Type: SystemBoolean
true to calculate area second moments. - productMoments
- Type: SystemBoolean
true to calculate area product moments.
Return Value
Type: AreaMassPropertiesThe AreaMassProperties for the given Surface or null on failure.

Exception | Condition |
---|---|
ArgumentNullException | When surface is null. |