RhinoCommon API
AreaMassPropertiesCompute Method (IEnumerableGeometryBase) |
Computes the Area properties for a collection of geometric objects.
At present only Breps, Surfaces, Meshes and Planar Closed Curves are supported.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.1

public static AreaMassProperties Compute( IEnumerable<GeometryBase> geometry )
Public Shared Function Compute ( geometry As IEnumerable(Of GeometryBase) ) As AreaMassProperties
Parameters
- geometry
- Type: System.Collections.GenericIEnumerableGeometryBase
Objects to include in the area computation.
Return Value
Type: AreaMassPropertiesThe Area properties for the entire collection or null on failure.