RhinoCommon API
BezierCurveGetControlVertex2d Method |
Get location of a control vertex.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public Point2d GetControlVertex2d( int index )
Public Function GetControlVertex2d ( index As Integer ) As Point2d
Parameters
- index
- Type: SystemInt32
Control vertex index (0 <= index < ControlVertexCount)
Return Value
Type: Point2dIf the bezier is rational, the euclidean location is returned.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | when index is out of range |