RhinoCommon API
BrepFaceListSplitClosedFaces Method |
Splits closed surfaces so they are not closed.
Namespace: Rhino.Geometry.Collections
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public bool SplitClosedFaces( int minimumDegree )
Public Function SplitClosedFaces ( minimumDegree As Integer ) As Boolean
Parameters
- minimumDegree
- Type: SystemInt32
If the degree of the surface < min_degree, the surface is not split. In some cases, minimumDegree = 2 is useful to preserve piecewise linear surfaces.
Return Value
Type: Booleantrue if successful.