MeshFaceNormalList.AddFaceNormal Method (Vector3f)

MeshFaceNormalListAddFaceNormal Method (Vector3f)

Appends a face normal to the list of mesh face normals.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int AddFaceNormal(
	Vector3f normal
)
Public Function AddFaceNormal ( 
	normal As Vector3f
) As Integer

Parameters

normal
Type: Rhino.GeometryVector3f
New face normal.

Return Value

Type: Int32
The index of the newly added face normal.
See Also