RhinoCommon API
CurveIsLinear Method (Double) |
Test a curve to see if it is linear to within the custom tolerance.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public bool IsLinear( double tolerance )
Public Function IsLinear ( tolerance As Double ) As Boolean
Parameters
- tolerance
- Type: SystemDouble
Tolerance to use when checking linearity.
Return Value
Type: Booleantrue if the ends of the curve are farther than tolerance apart and the maximum distance from any point on the curve to the line segment connecting the curve ends is <= tolerance.