RhinoCommon API
CurveTryGetArc Method (Arc, Double) |
Try to convert this curve into an Arc using a custom tolerance.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public bool TryGetArc( out Arc arc, double tolerance )
Public Function TryGetArc ( <OutAttribute> ByRef arc As Arc, tolerance As Double ) As Boolean
Parameters
- arc
- Type: Rhino.GeometryArc
On success, the Arc will be filled in. - tolerance
- Type: SystemDouble
Tolerance to use when checking.
Return Value
Type: Booleantrue if the curve could be converted into an arc.