Surface.Pullback Method (Curve, Double, Interval)

SurfacePullback Method (Curve, Double, Interval)

Pulls a 3d curve back to the surface's parameter space.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Curve Pullback(
	Curve curve3d,
	double tolerance,
	Interval curve3dSubdomain
)
Public Function Pullback ( 
	curve3d As Curve,
	tolerance As Double,
	curve3dSubdomain As Interval
) As Curve

Parameters

curve3d
Type: Rhino.GeometryCurve
A curve.
tolerance
Type: SystemDouble
the maximum acceptable 3d distance between from surface(curve_2d(t)) to the locus of points on the surface that are closest to curve_3d.
curve3dSubdomain
Type: Rhino.GeometryInterval
A sub-domain of the curve to sample.

Return Value

Type: Curve
2d curve.
See Also