RhinoCommon API
SurfaceTryGetPlane Method (Plane) |
Tests a surface for planarity and return the plane.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public bool TryGetPlane( out Plane plane )
Public Function TryGetPlane ( <OutAttribute> ByRef plane As Plane ) As Boolean
Parameters
- plane
- Type: Rhino.GeometryPlane
On success, the plane parameters are filled in.
Return Value
Type: Booleantrue if there is a plane such that the maximum distance from the surface to the plane is <= RhinoMath.ZeroTolerance.