RhinoCommon API
Vector3fMultiply Operator (Single, Vector3f) |
Multiplies a vector by a number, having the effect of scaling it.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0

public static Vector3f operator *( float t, Vector3f vector )
Public Shared Operator * ( t As Single, vector As Vector3f ) As Vector3f
Parameters
- t
- Type: SystemSingle
A number. - vector
- Type: Rhino.GeometryVector3f
A vector.
Return Value
Type: Vector3fA new vector that is the original vector coordinate-wise multiplied by t.