RhinoCommon API
GetBaseClassAddOptionEnumListT Method (String, T) |
Adds a choice of enumerated values as list option
Namespace: Rhino.Input.Custom
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.4

public int AddOptionEnumList<T>( string englishOptionName, T defaultValue ) where T : struct, new(), IConvertible
Public Function AddOptionEnumList(Of T As {Structure, New, IConvertible}) ( englishOptionName As String, defaultValue As T ) As Integer
Parameters
- englishOptionName
- Type: SystemString
The name of the option - defaultValue
- Type: T
The default value
Type Parameters
- T
- The enumerated type
Return Value
Type: Int32Option index

Exception | Condition |
---|---|
ArgumentException | Gets thrown if defaultValue provided is not an enumerated type. |