RhinoCommon API
SerializationOptions Class |
Contains options for serializing -or storing- data,
such as Rhino version and user data.

Namespace: Rhino.FileIO
Assembly: RhinoCommon (in RhinoCommon.dll)

The SerializationOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | SerializationOptions |
Initializes a new instance of the SerializationOptions class.
|

Name | Description | |
---|---|---|
![]() | RhinoVersion |
Gets or sets a value indicating the Rhino version.
|
![]() | WriteUserData |
Gets or sets a value indicating whether to write user data.
|

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |