RhinoCommon API
CurveSimplifyOptions Enumeration |
Enumerates the options to use when simplifying a curve.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 5.0


Member name | Value | Description | |
---|---|---|---|
None | 0 | No option is specified. | |
SplitAtFullyMultipleKnots | 1 | Split NurbsCurves at fully multiple knots. Effectively turning single NURBS segments with kinks into multiple segments. | |
RebuildLines | 2 | Replace linear segments with LineCurves. | |
RebuildArcs | 4 | Replace partially circular segments with ArcCurves. | |
RebuildRationals | 8 | Replace rational NURBS curve with constant weights with an equivalent non-rational NurbsCurve. | |
AdjustG1 | 16 | Adjust Curves at G1-joins. | |
Merge | 32 | Merge adjacent co-linear lines or co-circular arcs or combine consecutive line segments into a polyline. | |
All | 63 | Implies all of the simplification functions will be used. |