RhinoCommon API
MeshThicknessMeasurement Structure |
Thickness measurement used in the mesh thickness solver.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)

The MeshThicknessMeasurement type exposes the following members.

Name | Description | |
---|---|---|
![]() | MeshThicknessMeasurement |
Create a new thickness measurement.
|

Name | Description | |
---|---|---|
![]() | MeshIndex |
Gets the index of the mesh associated with this thickness measurement.
|
![]() | OppositePoint |
Gets the point opposite to the measurement point.
|
![]() | Point |
Gets the location of the thickness measurement.
|
![]() | Thickness |
Gets the local thickness of the mesh.
|
![]() | VertexIndex |
Gets the index of the vertex associated with this thickness measurement.
|

Name | Description | |
---|---|---|
![]() | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.) |
![]() | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.) |