RhinoCommon API
SweepTwoRail Class |
Utility class for generating Breps by sweeping cross section curves over two rail curves.
Note, this class has been superseded by the Rhino.Geometry.Brep.CreateFromSweep static functions.

Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)

The SweepTwoRail type exposes the following members.

Name | Description | |
---|---|---|
![]() | SweepTwoRail | Initializes a new instance of the SweepTwoRail class |

Name | Description | |
---|---|---|
![]() | AngleToleranceRadians |
Gets or sets the angle tolerance in radians.
|
![]() | ClosedSweep |
If the input rails are closed, ClosedSweep determines if the swept Breps will also be closed.
|
![]() | MaintainHeight |
Removes the association between the height scaling from the width scaling.
|
![]() | SweepTolerance |
Gets or sets the sweeping tolerance.
|

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | PerformSweep(Curve, Curve, Curve) |
Sweep2 function that fits a surface through profile curves that define the surface cross-sections
and two curves that defines a surface edge.
|
![]() | PerformSweep(Curve, Curve, IEnumerableCurve) |
Sweep2 function that fits a surface through profile curves that define the surface cross-sections
and two curves that defines a surface edge.
|
![]() | PerformSweep(Curve, Curve, Curve, Double, Double) | Obsolete. |
![]() | PerformSweep(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble) | Obsolete. |
![]() | PerformSweepRebuild(Curve, Curve, Curve, Int32) |
Sweep2 function that fits a surface through profile curves that define the surface cross-sections
and two curves that defines a surface edge.
|
![]() | PerformSweepRebuild(Curve, Curve, IEnumerableCurve, Int32) |
Sweep2 function that fits a surface through profile curves that define the surface cross-sections
and two curves that defines a surface edge.
|
![]() | PerformSweepRebuild(Curve, Curve, Curve, Double, Double, Int32) | Obsolete. |
![]() | PerformSweepRebuild(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble, Int32) | Obsolete. |
![]() | PerformSweepRefit(Curve, Curve, Curve, Double) |
Sweep2 function that fits a surface through profile curves that define the surface cross-sections
and two curves that defines a surface edge.
|
![]() | PerformSweepRefit(Curve, Curve, IEnumerableCurve, Double) |
Sweep2 function that fits a surface through profile curves that define the surface cross-sections
and two curves that defines a surface edge.
|
![]() | PerformSweepRefit(Curve, Curve, Curve, Double, Double, Double) | Obsolete. |
![]() | PerformSweepRefit(Curve, Curve, IEnumerableCurve, IEnumerableDouble, IEnumerableDouble, Double) | Obsolete. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |