RhinoCommon API
GpuDeviceInfo Class |
Represents a GPU device providing name, vendor and memory all as strings.
Currently fully implemented only on Windows.

Namespace: Rhino
Assembly: RhinoCommon (in RhinoCommon.dll)

The GpuDeviceInfo type exposes the following members.

Name | Description | |
---|---|---|
![]() | Memory |
Memory of the device in bytes
|
![]() | MemoryAsString |
Memory of the device as a human-readable string
|
![]() | Name |
Name of the device
|
![]() | Vendor |
Vendor of the device
|

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |