RhinoCommon API
PersistentSettingsEventArgsT Class |
Represents the persistent settings modification event arguments.

Namespace: Rhino
Assembly: RhinoCommon (in RhinoCommon.dll)

public class PersistentSettingsEventArgs<T> : PersistentSettingsEventArgs
Public Class PersistentSettingsEventArgs(Of T) Inherits PersistentSettingsEventArgs
Type Parameters
- T
- The type of the current and new setting that is being modified.
The PersistentSettingsEventArgsT type exposes the following members.

Name | Description | |
---|---|---|
![]() | PersistentSettingsEventArgsT | Initializes a new instance of the PersistentSettingsEventArgsT class |

Name | Description | |
---|---|---|
![]() | CurrentValue | |
![]() | NewValue |

Name | Description | |
---|---|---|