RhinoCommon API
RhinoDocObserverArgs Class |
Arguments passed to IRhinoDocObserver methods.

Namespace: Rhino
Assembly: RhinoCommon (in RhinoCommon.dll)

The RhinoDocObserverArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | RhinoDocObserverArgs | Initializes a new instance of the RhinoDocObserverArgs class |

Name | Description | |
---|---|---|
![]() | Doc |
Document
|
![]() | RuntimeSerialNumber |
Document runtime serial number, will be different across Rhino sessions.
|

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |