All descendants of this item (excluding item itself) within the model hierarchy
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Examples
CopySelect All Descentants
ModelItemCollection newCollection = new ModelItemCollection();
foreach (ModelItem item in Autodesk.Navisworks.Api.Application.ActiveDocument.CurrentSelection.SelectedItems)
{
newCollection.AddRange(item.Descendants);
}
Autodesk.Navisworks.Api.Application.ActiveDocument.CurrentSelection.CopyFrom(newCollection);
See Also