Occurs when BeginProgress() is called.
If any handler markes the event as handled, the standard progress dialog will not be displayed.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Examples
CopyProgress Events
Autodesk.Navisworks.Api.Application.ProgressBeginning += new EventHandler<Autodesk.Navisworks.Api.ProgressBeginningEventArgs>(Application_ProgressBeginning);
Autodesk.Navisworks.Api.Application.ProgressSubOperationBegan += new EventHandler<Autodesk.Navisworks.Api.ProgressSubOperationBeganEventArgs>(Application_ProgressSubOperationBegan);
Autodesk.Navisworks.Api.Application.ProgressUpdating += new EventHandler<Autodesk.Navisworks.Api.ProgressUpdatingEventArgs>(Application_ProgressUpdating);
Autodesk.Navisworks.Api.Application.ProgressErrorReporting += new EventHandler<Autodesk.Navisworks.Api.ProgressErrorReportingEventArgs>(Application_ProgressErrorReporting);
Autodesk.Navisworks.Api.Application.ProgressMessageReporting += new EventHandler<Autodesk.Navisworks.Api.ProgressMessageReportingEventArgs>(Application_ProgressMessageReporting);
Autodesk.Navisworks.Api.Application.ProgressSubOperationEnded += new EventHandler<Autodesk.Navisworks.Api.ProgressSubOperationEndedEventArgs>(Application_ProgressSubOperationEnded);
Autodesk.Navisworks.Api.Application.ProgressEnded += new EventHandler<Autodesk.Navisworks.Api.ProgressEndedEventArgs>(Application_ProgressEnded);
progressBar.ProgressBar.Maximum = 100;
void Application_ProgressBeginning(object sender, Autodesk.Navisworks.Api.ProgressBeginningEventArgs e)
{
statusText.Text = e.Title;
statusSubText.Text = string.Empty;
progressBar.Visible = true;
e.Handled = true;
statusStrip.Refresh();
}
See Also