|
![]() |
Event arguments used for the Application::ProgressBeginning event
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Class ProgressBeginningEventArgs _ Inherits ProgressEventArgs |
C# |
---|
public class ProgressBeginningEventArgs : ProgressEventArgs |
Visual C++ |
---|
public ref class ProgressBeginningEventArgs : public ProgressEventArgs |
Remarks
An instance of this class is passed with the Application.ProgressBeginning event.
Examples

Autodesk.Navisworks.Api.Application.ProgressBeginning += new EventHandler<Autodesk.Navisworks.Api.ProgressBeginningEventArgs>(Application_ProgressBeginning); Autodesk.Navisworks.Api.Application.ProgressSubOperationBegan += new EventHandler<Autodesk.Navisworks.Api.ProgressSubOperationBeganEventArgs>(Application_ProgressSubOperationBegan); Autodesk.Navisworks.Api.Application.ProgressUpdating += new EventHandler<Autodesk.Navisworks.Api.ProgressUpdatingEventArgs>(Application_ProgressUpdating); Autodesk.Navisworks.Api.Application.ProgressErrorReporting += new EventHandler<Autodesk.Navisworks.Api.ProgressErrorReportingEventArgs>(Application_ProgressErrorReporting); Autodesk.Navisworks.Api.Application.ProgressMessageReporting += new EventHandler<Autodesk.Navisworks.Api.ProgressMessageReportingEventArgs>(Application_ProgressMessageReporting); Autodesk.Navisworks.Api.Application.ProgressSubOperationEnded += new EventHandler<Autodesk.Navisworks.Api.ProgressSubOperationEndedEventArgs>(Application_ProgressSubOperationEnded); Autodesk.Navisworks.Api.Application.ProgressEnded += new EventHandler<Autodesk.Navisworks.Api.ProgressEndedEventArgs>(Application_ProgressEnded); progressBar.ProgressBar.Maximum = 100; //The following are the declarations for controls in a windows form //private System.Windows.Forms.StatusStrip statusStrip; //private System.Windows.Forms.ToolStripStatusLabel statusText; //private System.Windows.Forms.ToolStripProgressBar progressBar; //private System.Windows.Forms.ToolStripStatusLabel statusSubText; void Application_ProgressBeginning(object sender, Autodesk.Navisworks.Api.ProgressBeginningEventArgs e) { statusText.Text = e.Title; statusSubText.Text = string.Empty; progressBar.Visible = true; e.Handled = true; statusStrip.Refresh(); }
Inheritance Hierarchy
System..::..Object
System..::..EventArgs
Autodesk.Navisworks.Api..::..ProgressEventArgs
Autodesk.Navisworks.Api..::..ProgressBeginningEventArgs
System..::..EventArgs
Autodesk.Navisworks.Api..::..ProgressEventArgs
Autodesk.Navisworks.Api..::..ProgressBeginningEventArgs