|
![]() |
Return box that represents intersection of this with another box
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Function Intersect ( _ box As BoundingBox3D _ ) As BoundingBox3D |
C# |
---|
public BoundingBox3D Intersect( BoundingBox3D box ) |
Visual C++ |
---|
public: BoundingBox3D^ Intersect( BoundingBox3D^ box ) |
Parameters
Exceptions
Exception | Condition |
---|---|
System..::..ObjectDisposedException | Object has been Disposed |
System..::..ArgumentNullException | Argument 'box' is null |
System..::..ArgumentException | Argument 'box' has been Disposed |