|
![]() |
Namespace: Autodesk.Navisworks.Api.Clash
Assembly: Autodesk.Navisworks.Clash (in Autodesk.Navisworks.Clash.dll)
Syntax
Visual Basic |
---|
Public Sub TestsInsertCopy ( _ parent As GroupItem, _ index As Integer, _ item As SavedItem _ ) |
C# |
---|
public void TestsInsertCopy( GroupItem parent, int index, SavedItem item ) |
Visual C++ |
---|
public: void TestsInsertCopy( GroupItem^ parent, int index, SavedItem^ item ) |
Parameters
- parent
- Type: Autodesk.Navisworks.Api..::..GroupItem
The GroupItem contained in this document part to add to.
- index
- Type: System..::..Int32
The index at which to add the test.
- item
- Type: Autodesk.Navisworks.Api..::..SavedItem
The SavedItem to add. Must be suitable for the location it is being added, e.g. ClashTests can only be added to Value.Tests but ClashResults can be added to ClashTests or ClashResultGroups.
Exceptions
Exception | Condition |
---|---|
System..::..ArgumentException | Argument 'item' has been Disposed. |
System..::..ArgumentNullException | Argument 'item' is null. |
System..::..ArgumentException | Argument 'test' contains an unsupported type of SavedItem. |
System..::..ArgumentOutOfRangeException | Argument 'index' is out of range for the collection. |