|
![]() |
The exception that is thrown by file operation methods in Document
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
<SerializableAttribute> _ Public Class DocumentFileException _ Inherits IOException |
C# |
---|
[SerializableAttribute] public class DocumentFileException : IOException |
Visual C++ |
---|
[SerializableAttribute] public ref class DocumentFileException : public IOException |
Remarks
This exception can be thrown by various Document methods including:
- Document.OpenFile
- Document.AppendFile
- Document.AppendFiles
- Document.MergeFile
- Document.MergeFiles
- Document.PublishFile
- Document.SaveFile(System.String)
- Document.SaveFile(System.String,Autodesk.Navisworks.Api.DocumentFileVersion)
- Document.SetActiveSheet
When using the ApplicationAutomation methods from within a running instance of Navisworks the following methods may throw this Exception:
When using Automation and the equivalent functions in the Automation assembly directly, this exception will not be thrown but instead AutomationDocumentFileException.
For more information on Automation see 'Automation using the .NET API' in the 'Developer guide'.
Inheritance Hierarchy
System..::..Object
System..::..Exception
System..::..SystemException
System.IO..::..IOException
Autodesk.Navisworks.Api..::..DocumentFileException
System..::..Exception
System..::..SystemException
System.IO..::..IOException
Autodesk.Navisworks.Api..::..DocumentFileException