|
![]() |
Location of an AddInPlugin in the Navisworks menus system
Namespace: Autodesk.Navisworks.Api.Plugins
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Enumeration AddInLocation |
C# |
---|
public enum AddInLocation |
Visual C++ |
---|
public enum class AddInLocation |
Members
Member name | Description | |
---|---|---|
None | Do not display in the menus | |
AddIn | Display in the Addin menu | |
Import | Display in the Import menu | |
Export | Display in the Export menu | |
Help | Display in the Help menu | |
CurrentSelectionContextMenu | Display in the Context menu for currently selected ModelItem | |
CurrentSelection2DContextMenu | Display in the 2D Context menu for currently selected ModelItem |
Remarks
This enumeration is used with AddInPluginAttribute to identify where a plug-in appears in Navisworks.
Examples

[PluginAttribute("MessageSenderReceiver.MessageReceiver", //Plugin name "ADSK")] //4 character Developer ID or GUID [AddInPluginAttribute(AddInLocation.None)] //Identifies this as an Addin Plugin, that will not display in the ribbon public class MessageReceiver : AddInPlugin //Derives from AddInPlugin { public override int Execute(params string[] parameters) { //initialise a buffer to store the message String buffer = string.Empty; //Iterate the parameters and build the complete message foreach (String param in parameters) { buffer = buffer + "\r\n" + param; } //create the dialog to display to the user MessageReceived messageReceived = new MessageReceived(); //assign the message to be displayed messageReceived.Message = buffer; //Show the dialog messageReceived.ShowDialog(Autodesk.Navisworks.Api.Application.Gui.MainWindow); //return the the caller the value given by the user return messageReceived.ReturnValue; } }