|
![]() |
A plugin that can be called either using the GUI,
ApplicationAutomation
or using the Automation .NET API
Namespace: Autodesk.Navisworks.Api.Plugins
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Remarks
This class can be used as a base class for adding an executable plugin to Navisworks and optionally the GUI.
An attribute AddInPluginAttribute sets various properties for the plug-in.
The attribute PluginAttribute must be applied as this provides the unique information relating to any plug-in.
See Plug-ins and Writing Plug-ins for Navisworks for more information on creating plug-ins.

Examples

using System; using System.Collections.Generic; using System.Windows.Forms; using System.Text; //Add two new namespaces using Autodesk.Navisworks.Api; using Autodesk.Navisworks.Api.Plugins; namespace BasicPlugIn { [PluginAttribute("BasicPlugIn.ABasicPlugin", //Plugin name "ADSK", //4 character Developer ID or GUID ToolTip = "BasicPlugIn.ABasicPlugin tool tip",//The tooltip for the item in the ribbon DisplayName = "Hello World Plugin")] //Display name for the Plugin in the Ribbon public class ABasicPlugin : AddInPlugin //Derives from AddInPlugin { public override int Execute(params string[] parameters) { MessageBox.Show(Autodesk.Navisworks.Api.Application.Gui.MainWindow, "Hello World"); return 0; } } }
Inheritance Hierarchy
System..::..Object
Autodesk.Navisworks.Api.Plugins..::..Plugin
Autodesk.Navisworks.Api.Plugins..::..AddInPlugin
Autodesk.Navisworks.Api.Plugins..::..Plugin
Autodesk.Navisworks.Api.Plugins..::..AddInPlugin