Create a rebar shape definition with a given number of segments.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Syntax
C# |
---|
public RebarShapeDefinitionBySegments(
Document doc,
int numberOfSegments
) |
Visual Basic |
---|
Public Sub New ( _
doc As Document, _
numberOfSegments As Integer _
) |
Visual C++ |
---|
public:
RebarShapeDefinitionBySegments(
Document^ doc,
int numberOfSegments
) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
A document. The definition object is not a part of the document,
but it will contain references to parameters that are in a document.
The definition can be used for RebarShape creation only in the
specified document.
- numberOfSegments
- Type: System..::..Int32
The number of segments in the definition.
Exceptions
See Also