Interface that the Revit UI will call, if present, to construct the FrameworkElement
for the pane.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2018
Syntax
C# |
---|
public interface IFrameworkElementCreator |
Visual Basic |
---|
Public Interface IFrameworkElementCreator |
Visual C++ |
---|
public interface class IFrameworkElementCreator |
Examples
CopyC#
internal class BrowserCreator : IFrameworkElementCreator
{
public FrameworkElement CreateFrameworkElement()
{
return new WebBrowser();
}
}
CopyVB.NET
Friend Class BrowserCreator
Implements IFrameworkElementCreator
Public Function CreateFrameworkElement() As FrameworkElement Implements IFrameworkElementCreator.CreateFrameworkElement
Return New WebBrowser()
End Function
End Class
See Also