Autodesk.Revit.UI Namespace
 

Classes

  ClassDescription
Public classAddInCommandBinding
This object represents a binding between a Revit command and one or more handlers which override the behavior of the command in Revit.
Public classButtonData
Base class used to contain information necessary to construct a button in the Ribbon.
Public classColorSelectionDialog
Allows display of the Revit Color dialog.
Public classComboBox
This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.
Public classComboBoxData
This class contains information necessary to construct a combo box in the Ribbon.
Public classComboBoxMember
This class represents an item in the drop-down list of a ComboBox.
Public classComboBoxMemberData
This class contains information necessary to construct a ComboBoxMember.
Public classContextualHelp
Contains the details for how Revit should allow invocation of contextual help for an item added by an application.
Public classDockablePane
A user interface pane that participates in Revit's docking window system.
Public classDockablePaneId
Identifier for a pane that participates in the Revit docking window system.
Public classDockablePaneProviderData
Information about a new dockable pane being added to the Revit user interface.
Public classDockablePanes
Provides a container of all Revit built-in DockablePaneId instances.
Public classDockablePanes..::..BuiltInDockablePanes
A collection of ids of the dockable panes provided by Revit.
Public classDockablePaneState
Describes where a dockable pane window should appear in the Revit user interface.
Public classDoubleClickOptions
Provides access to settings that control what happens when the current user double-clicks on an element.
Public classEditorInteraction
Wraps the EditorInteractionType for the Pane to allow for clients to override their type dynamically if need be.
Public classExternalApplicationArray
An array that can contain any number of IExternalApplication objects.
Public classExternalApplicationArrayIterator
An iterator to an array of IExternalApplication objects..
Public classExternalCommandData
A class contains reference to Application and View which are needed by external command.
Public classExternalEvent
A class that represent an external event.
Public classFamilyInstancePlacingArgs
The class is used to access necessary data during the placement of a FamilyInstance.
Public classFileDialog
Base class supporting display of the dialog used to navigate to and select a file from Autodesk Revit.
Public classFileOpenDialog
This class allows an add-in to prompt the user with the Revit dialog used to navigate to and select an existing file path. This dialog is typically used to select a file for opening or importing.
Public classFileSaveDialog
This class allows an add-in to prompt the user with the Revit dialog used to navigate to and select an existing or new file path. This dialog is typically used to enter a file name for saving or exporting.
Public classFilterDialog
Allows display of the dialog used to create and edit FilterElements in Autodesk Revit.
Public classPreviewControl
Presents a preview control to browse the Revit model.
Public classPromptForFamilyInstancePlacementOptions
This class contains options to control the behavior of interactive placement of family instances.
Public classPulldownButton
The PulldownButton object represents a button with a drop-down list on RibbonPanel.
Public classPulldownButtonData
This class contains information necessary to construct a pulldown button in the Ribbon.
Public classPushButton
The PushButton object represents an button on a RibbonPanel.
Public classPushButtonData
This class contains information necessary to construct a push button in the Ribbon.
Public classRadioButtonGroup
Represents a group of related buttons in the Ribbon.
Public classRadioButtonGroupData
This class contains information necessary to construct a ribbon gallery in the Ribbon.
Public classRevitCommandId
Represents a command id in Autodesk Revit.
Public classRevitLinkUIUtils
A class containing functions for displaying user interface related to Revit links.
Public classRibbonButton
This class is the base class of PushButton and PulldownButton.
Public classRibbonItem
The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.
Public classRibbonItemData
Base class used to contain information necessary to construct a RibbonItem in the Ribbon.
Public classRibbonPanel
Represents a panel added by an External Application or External Command into the Add-Ins tab.
Public classSelectionUIOptions
Provides access to user settings related to how selection will behave in Revit's UI.
Public classSetupEnergySimulationDialog
The Revit dialog which typically precedes invocation of an Energy Simulation run on the Green Building Studio server.
Public classSplitButton
The SplitButton object represents a button with a clickable button appearing above a pulldown.
Public classSplitButtonData
This class contains information necessary to construct a split button in the Ribbon.
Public classTabbedDialogExtension
Contains the information required to create and implement the behavior for the new tab inside the Revit options dialog.
Public classTableViewUIUtils
This utility class contains members that involve the Revit UI and operate on schedule views or MEP electrical panel schedules.
Public classTaskDialog
A task dialog is a dialog box that can be used to display information and receive simple input from the user. It has a common set of controls that are arranged in a standard order to assure consistent look and feel.
Public classTextBox
The TextBox object represents text-based control that allows the user to enter text.
Public classTextBoxData
This class contains information necessary to construct a text box in the Ribbon.
Public classTextEditorOptions
Provides access to settings that control Revit's Text Editor appearance and functionality.
Public classThinLinesOptions
A utility class containing setting related to the Thin Lines option which affects the display in the UI.
Public classToggleButton
The ToggleButton object represents a button that has been added to a RadioButtonGroup.
Public classToggleButtonData
This class contains information necessary to construct a toggle button in a RadioButtonGroup.
Public classUIApplication
Represents an active session of the Autodesk Revit user interface, providing access to UI customization methods, events, the main window, and the active document.
Public classUIControlledApplication
Represents the Autodesk Revit user interface, providing access to UI customization methods and events.
Public classUIDocument
An object that represents an Autodesk Revit project opened in the Revit user interface.
Public classUIFabricationUtils
General Fabrication UI utility methods in Revit UI.
Public classUISaveAsOptions
This class contains UI options available for saving a document to disk with a new filename.
Public classUIThemeManager
Manager object for the UITheme class.
Public classUIView
A class containing data about view windows in the Revit user interface.

Interfaces

  InterfaceDescription
Public interfaceIControllableDropHandler
An interface to be executed when custom data is dragged and dropped onto the Revit user interface. This interface is different from IDropHandler in that it allows the handler to verify whether the drop event can be executed on the given view.
Public interfaceIDockablePaneProvider
Interface that the Revit UI will call during initialization of the user interface to gather information about add-in dockable pane windows.
Public interfaceIDropHandler
An interface to be executed when custom data is dragged and dropped onto the Revit user interface.
Public interfaceIExternalApplication
An interface that supports addition of external applications to Revit.
Public interfaceIExternalCommand
An interface that should be implemented to provide the implementation for a Revit add-in External Command.
Public interfaceIExternalCommandAvailability
An interface that should be implemented to provide the implementation for a accessibility check for a Revit add-in External Command.
Public interfaceIExternalEventHandler
An interface to be executed when an external event is raised.
Public interfaceIExternalResourceUIServer
The interface used to provide custom handling of UI operations related to external resources.
Public interfaceIFrameworkElementCreator
Interface that the Revit UI will call, if present, to construct the FrameworkElement for the pane.

Delegates

  DelegateDescription
Public delegateTabbedDialogAction
Delegate for tabbed dialog actions, such as OnOK, OnCancel and RestoreDefaults.

Enumerations

  EnumerationDescription
Public enumerationContextualHelpType
Represents the contextual help type.
Public enumerationDockPosition
Which part of the Revit application frame the pane should dock to.
Public enumerationDoubleClickAction
Possible actions Revit can take in response to the user double-clicking on an element.
Public enumerationDoubleClickTarget
Elements that support double-click in Revit. Note that this is meant to cover cases where the element itself is a double-click target. Individual controls that are targets are handled separately.
Public enumerationEditorInteractionType
Defines the type of interactions a pane has with the active editor when it becomes active in the Revit UI.
Public enumerationExternalEventRequest
Represents the possible outcomes of a request for raising an external event.
Public enumerationFaceBasedPlacementType
This enumerated type specifies options available for placement of a face-based family instance.
Public enumerationItemSelectionDialogResult
An enumerated type listing the possible responses from a prompted dialog where the user is asked to select one or more items.
Public enumerationPostableCommand
Enumerates all of the built-in commands which can be posted by an API application.
Public enumerationResult
Informs Autodesk Revit of the status of your application after execution.
Public enumerationRibbonItemType
An enumerated type listing all the toolbar item styles.
Public enumerationScrollbarVisibility
Lists all the visibility types of the scrollbar in the preview view.
Public enumerationSetupEnergySimulationDialogResult
Specifies identifiers to indicate the return value of the SetupEnergySimulationDialog
Public enumerationSketchGalleryOptions
Enumerates all the sketch options.
Public enumerationTab
An enumerated type listing static tabs which support addition of panels via the API.
Public enumerationTaskDialogCommandLinkId
Enum to specify the Id of CommandLink.
Public enumerationTaskDialogCommonButtons
A enumerated type containing the standard buttons available for Task Dialogs.
Public enumerationTaskDialogIcon
Standard icons to be used in the task dialog.
Public enumerationTaskDialogResult
Enum to specify the task dialog result.
Public enumerationUITheme
The application frame theme.