The Revit dialog which typically precedes invocation of an Energy Simulation run on the Green Building Studio server.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2016
Syntax
C# |
---|
public class SetupEnergySimulationDialog : IDisposable |
Visual Basic |
---|
Public Class SetupEnergySimulationDialog _ Implements IDisposable |
Visual C++ |
---|
public ref class SetupEnergySimulationDialog : IDisposable |
Remarks
Add-ins can invoke this dialog to collect the name and id of a Green Building Studio project and the name of an analysis run from the user. When the user chooses these values and opts to Continue, control returns the add-in to use the values the user has selected. No Green Building Studio run is automatically invoked by the user's actions in the dialog when it is prompted by the add-in.
This class can be instantiated only when the user is logged in to their Autodesk account.