Revit 2020 API |
FormattedText..::..GetPlainText Method (TextRange) |
FormattedText Class See Also |
Returns a substring of the text in a plain text form. The start and end of the substring is identified
by a given TextRange.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2017
Syntax
C# |
---|
public string GetPlainText( TextRange textRange ) |
Visual Basic |
---|
Public Function GetPlainText ( _ textRange As TextRange _ ) As String |
Visual C++ |
---|
public: String^ GetPlainText( TextRange^ textRange ) |
Parameters
- textRange
- Type: Autodesk.Revit.DB..::..TextRange
The given TextRange.
Return Value
The substring of the text in a plain text form.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |