Revit 2020 API |
Autodesk.Revit.DB.Macros Namespace |
Classes
Class | Description | |
---|---|---|
![]() | AddInIdAttribute | The custom AddInId attribute for Macros macros use only. |
![]() | ApplicationEntryPoint | For Revit Macros use only. |
![]() | DocumentEntryPoint | For Revit Macros use only. |
![]() | Macro |
An individual Autodesk Revit Macro which can be executed.
|
![]() | MacroManager |
Manager object for the Macro modules of the application.
|
![]() | MacroManagerIterator |
An iterator to a MacroManager.
|
![]() | MacroModule |
A container for individual macros. As it relates to the macros editor, one MacroModule represents
a project that can be loaded and edited from within the editor.
|
![]() | MacroModuleIterator |
An iterator to the Macros in a MacroModule.
|
![]() | ModuleSettings |
The module settings.
|
![]() | VendorIdAttribute | The custom VendorId attribute for Macros macros use only. |
Interfaces
Interface | Description | |
---|---|---|
![]() | IEntryPoint | The interface supporting Document and Application level entry point classes for macros. |
Enumerations
Enumeration | Description | |
---|---|---|
![]() | ApplicationMacroOptions |
The application macro options.
|
![]() | DocumentMacroOptions |
The document macro options.
|
![]() | MacroEnvironment |
The Macro environments.
|
![]() | MacroLanguageType |
The Macro language types.
|
![]() | MacroLevel |
The Macro levels.
|
![]() | ModuleStatus |
The Macro module status.
|