Autodesk.Revit.DB.Analysis Namespace
 

Classes

  ClassDescription
Public classAnalysisDisplayColoredSurfaceSettings
Contains colored surface settings for analysis display style element.
Public classAnalysisDisplayColorEntry
Contains one entry of intermediate colors in color settings for analysis display style.
Public classAnalysisDisplayColorSettings
Contains color settings for analysis display style element.
Public classAnalysisDisplayDeformedShapeSettings
Contains deformed shape settings for analysis display style element.
Public classAnalysisDisplayDiagramSettings
Contains diagram settings for analysis display style element.
Public classAnalysisDisplayLegend
The legend that describes an Analysis Visualization.
Public classAnalysisDisplayLegendSettings
Contains legend settings for analysis display style element.
Public classAnalysisDisplayMarkersAndTextSettings
Contains markers and text settings for analysis display style element.
Public classAnalysisDisplayStyle
Exposes API for manipulation of analysis display style.
Public classAnalysisDisplayVectorSettings
Contains vector settings for analysis display style element.
Public classAnalysisResultSchema
Contains all information about one analysis result. Each result may contain several measurements.
Public classBuildingEnvelopeAnalyzer
Analyzes which elements are part of the building envelope, the building elements exposed to the outside.
Public classBuildingEnvelopeAnalyzerOptions
Specific options for the method analyzing the building elements for the building envelope.
Public classConceptualConstructionType
This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization
Public classConceptualSurfaceType
This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization
Public classEnergyAnalysisDetailModel
Manage the analytical thermal model.
Public classEnergyAnalysisDetailModelOptions
Options that govern the calculations for the generation of the energy analysis detail model.
Public classEnergyAnalysisOpening
Analytical opening.
Public classEnergyAnalysisSpace
Analytical space.
Public classEnergyAnalysisSurface
Analytical surface. The collection of analytic openings belonging to this analytical parent surface
Public classEnergyDataSettings
This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization
Public classFieldDomainPoints
Abstract base class for various classes of field domain points
Public classFieldDomainPointsByParameter
Represents a set of one-dimensional point coordinates (defined usually on curve)
Public classFieldDomainPointsByUV
Represents a set of two-dimensional point coordinates (defined usually on surface)
Public classFieldDomainPointsByXYZ
Represents a set of three-dimensional point coordinates
Public classFieldValues
Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.
Public classGenericZoneDomainData
A base class for specific domain requirements for a generic zone.
Public classHVACLoadBuildingType
The type element of building.
Public classHVACLoadSpaceType
The type element of space.
Public classHVACLoadType
The base class for building type and space type.
Public classMassEnergyAnalyticalModel
This class associates a mass instance with an energy analytical model data and geometry.
Public classMassGBXMLExportOptions
Options used when exporting a gbXML file from a mass model document.
Public classMassLevelData
MassLevelData is a conceptual representation of an occupiable floor (Mass Floor) in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.
Public classMassSurfaceData
Holds properties and other data about a face in the MassEnergyAnalyticalModel element.
Public classMassZone
MassZones are created from the MassEnergyAnalyticalModel. They are conceptual representations of individually heated and cooled sub-volumes of a building.
Public classPathOfTravel
An element which holds a graphical representation of the shortest route between two points in the plane of a floor plan view. The shortest route is calculated to go around model geometry visible in the view. Route calculation is affected by properties of the RouteAnalysisSettings element.
Public classPathOfTravelCalculationServerIds
Ids for external servers implementing path of travel calculations.
Public classPolyloop
A Polyloop represent a planar polygon with ordered points.
Public classRouteAnalysisSettings

RouteAnalysisSettings is an element which contains project-wide settings for route calculations. The PathOfTravel element uses these settings to calculate a route between two points in a plan view.

By default, the route will go around the geometry of all visible model elements which have model geometry in the Route Analysis Zone.

The Route Analysis Zone, determined per view, is the space between these two horizontal planes: a top plane vertically offset by AnalysisZoneTopOffset above the view's level and a bottom plane vertically offset by AnalysisZoneBottomOffset ft above the view's level.

By default, the route will ignore the following elements:
  • elements outside of the crop region of the view;
  • elements without any model geometry (annotations or view-specific elements);
  • model lines (category OST_Lines);
  • demolished elements;
  • elements displayed in the underlay of the view.
There are a few ways to customize Route Analysis on a project-wide basis.

You can adjust the Route Analysis Zone using AnalysisZoneTopOffset and AnalysisZoneBottomOffset.

You can specify a set of model categories you would like ignored during route calculation. To enable ignoring the set of specified categories, set EnableIgnoredCategoryIds to true. To change the set of ignored categories, use SetIgnoredCategoryIds method and IgnoreImports and IgnorePointClouds properties. To query the set of ignored categories, use GetIgnoredCategoryIds.

Public classSpatialFieldManager
Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.
Public classValueAtPoint
Stores values at one domain point. Each value corresponds to a "measurement" for which this value was calculated.
Public classVectorAtPoint
Stores vectors at one domain point. Each vector corresponds to a "measurement" for which this vector was calculated.

Enumerations

  EnumerationDescription
Public enumerationAllowLargeGeometry
An enumerated type containing settings information related to handling of large geometries.
Public enumerationAnalysisDisplayStyleColorSettingsType
Defines types for color settings of analysis display style.
Public enumerationAnalysisDisplayStyleDeformedShapeTextLabelType
Defines text visualization types for deformed shape settings of analysis display style.
Public enumerationAnalysisDisplayStyleDiagramFenceType
Defines fence visualization types for diagram settings of analysis display style.
Public enumerationAnalysisDisplayStyleDiagramTextLabelType
Defines text label visualization types for diagram settings of analysis display style.
Public enumerationAnalysisDisplayStyleMarkerTextLabelType
Text label visualization types for Markers and Text settings of analysis display style.
Public enumerationAnalysisDisplayStyleMarkerType
Marker types for Markers and Text settings of analysis display style.
Public enumerationAnalysisDisplayStyleVectorArrowheadScale
Defines arrow head scaling for vector settings of analysis display style.
Public enumerationAnalysisDisplayStyleVectorOrientation
Defines vector orientation for vector settings of analysis display style.
Public enumerationAnalysisDisplayStyleVectorPosition
Defines vector position for vector settings of analysis display style.
Public enumerationAnalysisDisplayStyleVectorTextType
Defines text visualization types for vector settings of analysis display style.
Public enumerationAnalysisMode
This enum is used to define the Energy Analysis Model.
Public enumerationConceptualConstructionFloorSlabType
ConceptualConstructionType values for Floors.
Public enumerationConceptualConstructionOpeningType
ConceptualConstructionType values for Openings.
Public enumerationConceptualConstructionRoofType
ConceptualConstructionType values for Roofs.
Public enumerationConceptualConstructionShadeType
ConceptualConstructionType values for Shades.
Public enumerationConceptualConstructionWallType
ConceptualConstructionType values for Walls.
Public enumerationConceptualConstructionWindowSkylightType
ConceptualConstructionType values for Windows and Skylights
Public enumerationConstructionType
This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.
Public enumerationEnergyAnalysisDetailModelTier
Level of computation for energy analysis model.
Public enumerationEnergyAnalysisOpeningType
Energy analysis opening type.
Public enumerationEnergyAnalysisSurfaceType
Analytical surface types.
Public enumerationEnergyModelType
This enum is used to define if the energy model is based on rooms/spaces or building elements.
Public enumerationgbXMLBuildingHVACSystem
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumerationgbXMLBuildingOperatingSchedule
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumerationgbXMLBuildingType
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumerationgbXMLConditionType
This enumeration corresponds to the conditionType attribute in gbXML. The enumerated attribute identifies the type of heating, cooling, or ventilation the space has.
Public enumerationgbXMLExportBuildingEnvelope
Indicates the determination method for the building envelope
Public enumerationgbXMLExportComplexity
This enumeration specifies the level of detail of the exported analytical energy model in gbXML. Complex means that Curtain Walls and Curtain Systems are exported as several openings, panel by panel; a curtain wall with 50 panels gets exported as 50 openings. Simple means that one "huge" opening with the total opening area equal to the 50 panels is exported. This is more appropriate for most energy analysis. Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
Public enumerationgbXMLOpeningType
This enumeration corresponds to the openingType attribute in gbXML and identifies the type of opening defined.
Public enumerationgbXMLServiceType
This enumeration corresponds to the systemType attribute in gbXML and is used for specifying the service for the building or space.
Public enumerationgbXMLSpaceType
This enumeration corresponds to the spaceType attribute in gbXML. The enumerated attribute identifies the type of space defined and allows to better approximate the actual internal loads and schedules associated with the defined space type.
Public enumerationgbXMLSurfaceType
This enumeration corresponds to the surfaceType attribute in gbXML and identifies the type of surface defined.
Public enumerationHVACLoadConstructionClass
Enumerated type listing options for construction class for HVAC analysis.
Public enumerationHVACLoadLoadsReportType
Enumerated type listing possible types of reports generated for HVAC loads.
Public enumerationMassSurfaceDataMaterialType
Indicates how the visualization material for the MassSurfaceData is calculated.
Public enumerationMassSurfaceDataSource
Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.
Public enumerationMassZoneLevelCutState
The relationship between lower level or upper level and the MassZone. The MassZone is not intersected by this level, this level just happens to be the nearest upper or lower level. The MassZone was created by cutting its source geometry with this level. The level cuts through the MassZone geometry. One or more faces of the MassZone are coincident with this level and the level does not otherwise cut through or intersect the MassZone geometry.
Public enumerationMassZoneMaterialType
MassZone material type.
Public enumerationOutdoorAirFlowStandard
An enumerated type listing all the possible outdoor airflow standard for a space type.
Public enumerationPathOfTravelCalculationRequestType
An enumerated type containing possible requests for the Path of Travel calculation.
Public enumerationPathOfTravelCalculationStatus
An enumerated type containing possible results of the Path of Travel calculation.
Public enumerationSpatialFieldPrimitiveHideMode
Defines modes which can be used by a SpatialFieldPrimitive to hide the original referenced element.