Contains legend settings for analysis display style element.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2011
Syntax
C# |
---|
public class AnalysisDisplayLegendSettings : IDisposable |
Visual Basic |
---|
Public Class AnalysisDisplayLegendSettings _
Implements IDisposable |
Visual C++ |
---|
public ref class AnalysisDisplayLegendSettings : IDisposable |
Examples
CopyC#
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.NumberOfSteps = 10;
legendSettings.Rounding = 0.05;
legendSettings.ShowDataDescription = false;
legendSettings.ShowLegend = true;
CopyVB.NET
Dim legendSettings As New AnalysisDisplayLegendSettings()
legendSettings.NumberOfSteps = 10
legendSettings.Rounding = 0.05
legendSettings.ShowDataDescription = False
legendSettings.ShowLegend = True
Inheritance Hierarchy
See Also