The filter string representing a collection of extensions allowed by the dialog.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 20.0.0.0 (20.0.0.377)
Since:
2017
Syntax
C# |
---|
public string Filter { get; set; } |
Visual Basic |
---|
Public Property Filter As String
Get
Set |
Field Value
The required format for this string is a collection of one or more filter labels (representing the text
the user will see in the Files of Type pulldown) plus an associated file matching string separated by the
'|' character.
Some examples of valid filter strings:
- "Revit Files (*.rvt)|*.rvt
- "Revit Projects (*.rvt)|*.rvt|Revit Families (*.rfa)|*.rfa"
- "All files|*.*"
- "All Revit files (*.rvt, *.rfa, *.rte, *.rft)|*.rvt;*.rfa;*.rte;*.rft"
Exceptions
See Also